Na proxmox2 se pustí LXC kontejner aribuild2

Aktuální verze EOS-4.18.8M-CZF-v2.swi

  1. admin@ (správa switche a IP adres přes CLI)
  2. root@ (správa linuxu, vtysh atp)

Konfigurace po změnách lze uložit přes (sync se volá periodicky v /etc/cron.daily a také při shutdownu / rebootu):

  • /root/sync-config.sh –stop

Tento skript synchronizuje:

  • /etc/dhcp/dhcpd.conf
  • /etc/resolv.conf
  • /etc/switches.conf
  • /etc/ntp.conf
  • /etc/rsyslog.conf
  • /etc/switches_definitions.conf
  • /etc/sudoers
  • /etc/quagga/*
  • /opt/HotSaNIC/*
  • /root/.ssh/*

Změny v jiných než výše uvedených konfigurákách budou při rebootu ztraceny. V případě, že bude potřeba synchronizovat i nějaké další, je potřeba upravit skript sync-config.sh a vygenerovat s ním nový boot image.

Při přidávání více IP adres na jeden, stejný interface

  • ip address 1.1.1.1/24
  • ip address 1.1.1.2/24 secondary
  • ip address 1.1.1.3/24 secondary

Konfigurace NTP v EOS:

  • ntp server 10.33.0.23
  • ntp server 10.33.0.25
  • ntp server 0.rhel.ntp.pool.org
  • ntp server ntp.nic.cz
  • ntp server tak.cesnet.cz
  • ntp serve all

Workaround který musí být v konfiguraci EOSu jako workaround na problém mezi systemd závislostmi a tím jak Arista dělá HW bringup:

 event-handler dhcpd_fix
    trigger on-boot
    action bash /usr/sbin/service dhcpd restart

Jinak po bootu nenaběhne v Linuxu dhcpd (startuje příliš brzo a nemá konfigurák).


Jak přidat novou spojovačku s OSPF?

  • login jako admin@,
  • jab414>en
  • jab414#configure terminal
  • jab414(config)#interface vlan 10
  • jab414(config-if-Vl10)#ip address 10.0.0.1/30
  • jab414(config)#write mem
  • Copy completed successfully.
  • jab414(config)#
  • login jako root@
  • Arista Networks EOS shell
  • [root@jab414 ~]$ vtysh
  • Hello, this is Quagga (version 0.99.21).
  • Copyright 1996-2005 Kunihiro Ishiguro, et al.
  • jab414# configure terminal
  • jab414(config)# router ospf
  • jab414(config-router)# network 10.0.0.0/30 area 0.0.0.0
  • jab414(config-router)# exit
  • jab414(config)# exit
  • jab414# write mem
  • Building Configuration…
  • Configuration saved to /etc/quagga/zebra.conf
  • Configuration saved to /etc/quagga/ospfd.conf
  • [OK]
  • jab414#exit
  • [root@jab414 ~]$ /root/sync-config.sh –stop
  • sending incremental file list

Grafana < Prometheus < Ocprometheus < TerminAttr

 daemon OCPrometheus
    exec /mnt/flash/persist/bin/ocprometheus -config /mnt/flash/persist/conf/ocprometheus.yml -addr 
  localhost:<port> -listenaddr :<port>
    no shutdown
 !
 daemon TerminAttr
    exec /usr/bin/TerminAttr -grpcaddr localhost:<port> -disableaaa
    no shutdown
Tisk/export